Commit 253f2042 authored by Théo | Ailé's avatar Théo | Ailé 💬
Browse files

Merge branch '125-fix-family-tree' into 'master'

Ajout de pygraphviz en dépendance

Closes #125

On change également la version minimale de python (`3.7` -> `3.8`)

Closes #125

See merge request !306
parents 2422f608 7241f3eb
Pipeline #2511 passed with stage
in 46 minutes and 29 seconds
......@@ -21,7 +21,7 @@ unittests:
- poetry run ./manage.py compilemessages
# Run tests and export report
- poetry run coverage run ./manage.py test
- poetry run coverage html
- poetry run coverage xml
- poetry run coverage report
# Build documentation
- cd doc
......@@ -32,9 +32,13 @@ unittests:
paths:
- .cache/pip_tests
artifacts:
when: always
paths:
- coverage.xml
- coverage_report/
- docs/_build
reports:
junit: coverage.xml
# Check black
black:
......
......@@ -19,7 +19,7 @@ homepage = "https://ae.utbm.fr/"
license = "GPL-3.0-only"
[tool.poetry.dependencies]
python = "^3.7"
python = "^3.8"
Django = "^2.2"
Pillow = "^8.3.2"
mistune = "^0.8.4"
......@@ -41,7 +41,7 @@ django-simple-captcha = "^0.5.14"
python-dateutil = "^2.8.2"
psycopg2-binary = "2.8.6"
sentry-sdk = "^1.4.3"
graphviz = "^0.17"
pygraphviz = "^1.9"
Jinja2 = "<=3.0.3"
# Extra optional dependencies
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment